OpsCenter 4.0 User Guide

The SSTables in this snapshot '<tag>' are not compatible

If you receive an error message that includes "The SSTables in this snapshot '<tag>' are not compatible with the current version of Cassandra", it means you must upgrade your snapshot to the current major version of Cassandra or DSE.

How to
  1. Log in to each node.
  2. Run the sstableupgrade script for every keyspace and column family you wish to restore, passing it the keyspace, column family, and OpsCenter snapshot tag that you got from the error message.

    How you run the script depends on how you installed Cassandra or DSE.

  3. Retry the restore from OpsCenter.
Show/hide