OpsCenter 4.0 User Guide

Python used to run OpsCenter not built with SSL

In order to protect your AWS credentials when launching EC2 instances, OpsCenter needs to use HTTPS, but if the version of Python that is running opscenterd was not compiled with SSL support OpsCenter will not run even if SSL has been disabled in the configuration file.

To resolve the issue, first ensure that OpenSSL 0.9.8 is installed on your system. If you have compiled Python manually, it is recommended that you install Python 2.6+ through your package manager. On CentOS and RedHat Enterprise Linux, this is most easily done through EPEL packages.

If you must compile Python manually, make sure that SSL support is enabled. This blog post explains the process for Python 2.5, but the same steps will work for Python 2.6 or 2.7.

Show/hide