OpsCenter 4.0 User Guide

Error exceptions.ImportError:libssl.so.0.9.8

Occurs when OpenSSL 1.0.0 is installed on RHEL 5.x, CentOS 5.x, OEL 5.5, Debian, or Ubuntu systems:

message.exceptions.ImportError: libssl.so.0.9.8

To fix, you can do either of the following:

  • Install OpenSSL 0.9.8:
    1. RHEL-based systems: sudo yum install openssl098
    2. Debian-based systems: sudo apt-get install libssl0.9.8
  • Install Python libssl 1.x:
    1. Remove all OpenSSL modules from the OpsCenter installation lib directory. You do not have to remove them globally.

      Packaged installs: /usr/share/opscenter/content/lib

      Tarball installs: <install_location>/lib

      You can easily find these directories using:

      find . -name OpenSSL -type d | xargs rm -rf
    2. Install the latest pyOpenSSL module:

      Debian-based systems: apt-get install python-openssl

      RHEL-based systems: yum install python-openssl

    3. Start or restart opscenterd.
Show/hide